No subject

Thu Jun 25 05:52:11 EDT 2020

renaming the leds. but I'm sure you have a better general view than I.
I'm fine to skip this patch of the series and fix the DSL led of the
affected boards after renaming the leds.

I totally agree with you, that the led naming is suboptimal. I'm
currently working on adding support for systems which are using three
leds for boot state indication. I had to rewrite the whole,
with the benefit that we can get rid of the static power[0-2] naming
as well. With having led names like power[0-2] without any indication
which colour the led has, it's a mess to ensure that I don't break
existing power led setups.

Am I right that you are talking about a naming scheme like
"devicename:colour:function" as it's suggested by

Are there any known limitations for the led node names, which are
available at /sys/class/leds/*/device/of_node/? Maybe we can use node
names according to the intended (OpenWrt) use and prevent bloating the
board.d led file this way after switching to the
devicename:colour:function naming.

Are you working on renaming the leds or are you wait for patches?
openwrt-devel mailing list
openwrt-devel at

More information about the openwrt-devel mailing list