[RFC PATCH v2 0/1] Introduce UCI support for configuring DSA VLAN filter rules
Josh Bendavid
joshbendavid at gmail.com
Thu Jul 23 05:15:58 EDT 2020
Ok thanks, I agree this makes much more sense.
As Luiz mentioned earlier, this exposes more explicitly the
awkwardness of the "network" option for wifi-iface pointing to an
interface rather than a device.
Related to this, is it possible to add a wireless interface to a
bridge specifying a non-default PVID? I guess this is needed if one
wants to run multiple wireless interfaces off a single bridge with
different vlans.
On Thu, 23 Jul 2020 at 08:53, Jo-Philipp Wich <jo at mein.io> wrote:
>
> Hi,
>
> > One thing which is a bit awkward as long as the bridge itself is
> > configured as an interface, is that as far as I have understood,
> > creating a tagged interface to the bridge requires first setting up an
> > interface for the bridge, e.g. with protocol Unmanaged, and then
> > setting up one or more vlan tagged interfaces on top of it which can
> > then be configured with ip addresses.
> The following configuration:
>
> config interface foo
> option type bridge
> option ifname 'bar baz qrx'
> option proto ...
>
> Is actually a convenience shortcut for:
>
> config device
> option type bridge
> option name br-foo
> list ifname bar
> list ifname baz
> list ifname qrx
>
> config interface foo
> option ifname br-foo
> option proto ...
>
> So in order to define a bridge interface without IP configuration,
> you could solely use:
>
> config device
> option type bridge
> option name mybridge0
> list ifname lan1
> list ifname lan2
> ...
>
> This has a couple of advantages:
>
> - You don't need a logical dummy interface
> - You can get rid of the implicit "br-" prefix
> - The resulting configuration becomes more explicit
>
>
> Regards,
> Jo
>
More information about the openwrt-devel
mailing list