'tr' character class support?

Jordan Geoghegan jordan at geoghegan.ca
Fri Jul 10 16:45:12 EDT 2020

Hey folks,

Does the 'tr' utility support character classes in OpenWRT? I was 
playing around with an OpenWRT x86_64 VM and I noticed that 'tr' doesn't 
seem to support character classes.
The command " echo HELLO | tr '[:upper:]' '[:lower:]' "  does not 
convert to the text to lowercase as it should (and as required by 
POSIX). I'm 99.9% sure BusyBox 'tr' supports character classes, as when 
I tried it on Alpine Linux (which uses BusyBox) everything worked as 

I wanted to make sure this wasn't just a fluke with the x86_64 build, so 
I had another person test it on arm and mips releases and he was able to 
confirm the issue (and additionally confirmed that the issue is also 
present in LibreCMC which is based on OpenWRT). Anyways, just hoping I 
could get some clarification as to what the story is with 'tr' and 
character classes.



More information about the openwrt-devel mailing list