[OpenWrt-Devel] [PATCH] package: use PKG_VERSION only for upstream packages

Paul Oranje por at oranjevos.nl
Sun Aug 9 05:02:28 EDT 2020

Op 24 feb. 2020, om 17:08 heeft Adrian Schmutzler <freifunk at adrianschmutzler.de> het volgende geschreven:
> In the package guidelines, PKG_VERSION is supposed to be used
> as "The upstream version number that we're downloading", while
> PKG_RELEASE is referred to as "The version of this package Makefile".
> Thus, the variables in a strict interpretation provide a clear
> distinction between "their" (upstream) version in PKG_VERSION and
> "our" (local OpenWrt trunk) version in PKG_RELEASE.

As still some discussion exists about how to use PKG_VERSION and PKG_RELEASE, currently around local projects, a thought of some time ago might be worth consideration.

The wiki states that PKG_RELEASE must be reset to 1 whenever PKG_VERSION is updated [1], which makes it subordinate to the upstream version of the package. Would just keep incrementing PKG_RELEASE not be less entangled (of orthogonal purposes) ?

Also, might it be an idea to rename PKG_VERSION to PKG_UPSTREAM_VERSION ? (or something alike but more concise)
That would make its meaning much more obvious.

[1] https://openwrt.org/docs/guide-developer/package-policies

More information about the openwrt-devel mailing list