[OpenWrt-Devel] [PATCH] ath79: switch to kernel 5.4

mail at adrianschmutzler.de mail at adrianschmutzler.de
Mon Apr 6 05:46:36 EDT 2020


I've just quickly tested a few devices with "default" setup plus the inlining-patch on kernel 5.4:

TP-Link Archer C60 v1: works without apparent issues
TP-Link TL-WR841N v12 (tiny!): works without apparent issues, it is still possible to write to flash
TP-Link TL-WR1043ND v4: boots fine, WAN+Wifi works, I had some issues with WAN+LAN where network on my client device froze as soon as I tried to do a speed test (though I cannot clearly admit that to the router, it might be a problem on my client device as well; rebooting the client device fixed it until I tried to measure speed again). However, note that this is the only device tested where the WAN port is part of the switch (eth0.2).

dmesg is clean for all devices, nothing remarkable.



> -----Original Message-----
> From: openwrt-devel [mailto:openwrt-devel-bounces at lists.openwrt.org]
> On Behalf Of Bjørn Mork
> Sent: Freitag, 3. April 2020 21:51
> To: mail at adrianschmutzler.de
> Cc: 'openwrt-devel' <openwrt-devel at lists.openwrt.org>; 'Russell Senior'
> <russell at personaltelco.net>; 'David Bauer' <mail at david-bauer.net>;
> 'Magnus Kroken' <mkroken at gmail.com>
> Subject: Re: [OpenWrt-Devel] [PATCH] ath79: switch to kernel 5.4
> <mail at adrianschmutzler.de> writes:
> >> AP is now revived *with* v5.4 built with gcc-8.4.0.
> >
> > So, this is sorted out?
> Well... There is a kernel patch which seems to work for me, and that's all.
> But I'm unable to write any meaningful commit message explaining it.  So this
> still needs to be looked at by someone with a clue...
> I don't think 5.4 should be made default for ath79 before this is sorted out
> properly.
> > If further testing is required, I have a Unifi AC Mesh and several
> > TP-Link devices at hand (but only limited time for testing).  I might
> > also try what happens on tiny ...
> Further testing is definitely necessary. Maybe those with an already crashing
> device could start?
> Bjørn
> _______________________________________________
> openwrt-devel mailing list
> openwrt-devel at lists.openwrt.org
> https://lists.openwrt.org/mailman/listinfo/openwrt-devel
-------------- next part --------------
A non-text attachment was scrubbed...
Name: openpgp-digital-signature.asc
Type: application/pgp-signature
Size: 834 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20200406/82ea2246/attachment.sig>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list