[OpenWrt-Devel] [PATCH 6/8] mvebu: add vendor to device names

Tomasz Maciej Nowak tomek_n at o2.pl
Mon May 6 11:48:27 EDT 2019

W dniu 05.05.2019 o 22:42, Petr Štetiar pisze:
> Tomasz Maciej Nowak <tomek_n at o2.pl> [2019-05-04 16:01:11]:
>> W dniu 04.05.2019 o 00:38, Petr Štetiar pisze:
>>> SUPPORTED_DEVICES variable is used for this, so it's probably going to work,
>>> but if we're willing to rename it, it might be a good idea to follow the DT
>>> compatible naming scheme as used in other targets.
>>> So instead of this in patch 4/8:
>>>  +  SUPPORTED_DEVICES = $$(firstword $$(DEVICE_DTS))
>>> Tomasz should be doing following:
>>>  +  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
>> Ideally that would be the case, unfortunately there is inconsistency in the upstream
>> dtses, for example (stand after my patch renaming device names):
> from my POV, it seems more convenient to stick to DT compatible, as it's then
> going to be referenced in the other places as well, so it's probably going to
> mean less confusion.
>> linksys-wrt1200ac has compatible linksys,caiman,
> I could still grep for wrt1200ac with the following code and find out the
> proper device/image:
>  Device/linksys_caiman
>    $(call Device/linksys,WRT1200AC (Caiman))
>    SUPPORTED_DEVICES += linksys-wrt1200ac
>    ...
>  endef
>  TARGET_DEVICES += linksys_caiman

That would be convenient for us but not for the person searching for firmware in
download directory. Please read the commit message what was the intention of this patch.

> and if we're going to rename it, we should fix all the references in the wiki as well.
>> marvell-armada-385-db-ap -> marvell,a385-db-ap
>> marvell-armada-3720-db -> marvell,armada-3720-db
>> marvell-armada-8040-db -> marvell,armada8040-db
> seems ok to me.

That's also ok with me. These are dev boards so someone possessing it, would
identify them without problem.

>> marvell-macchiatobin -> marvell,armada8040-mcbin
> quite weird, but that's a life, still DEVICE_TITLE is going to make it clear.

DEVICE_TITLE is not visible in download directory, with this we'll add to the
confusion instead of reducing it.

I'll prepare v2 with something in the middle of what was discussed.


openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list