[OpenWrt-Devel] [PATCH v13] ath10k: add LED and GPIO controlling support for various chipsets

Sven Eckelmann sven at narfation.org
Tue Feb 26 04:16:05 EST 2019


On Friday, 6 April 2018 17:17:55 CET Kalle Valo wrote:
> From: Sebastian Gottschall <s.gottschall at newmedia-net.de>
> 
> Adds LED and GPIO Control support for 988x, 9887, 9888, 99x0, 9984 based
> chipsets with on chipset connected led's using WMI Firmware API.  The LED
> device will get available named as "ath10k-phyX" at sysfs and can be controlled
> with various triggers.  adds also debugfs interface for gpio control.
> 
> Signed-off-by: Sebastian Gottschall <s.gottschall at dd-wrt.com>
> Reviewed-by: Steve deRosier <derosier at cal-sierra.com>
> [kvalo: major reorg and cleanup]
> Signed-off-by: Kalle Valo <kvalo at codeaurora.org>


This patch was imported to OpenWrt in commit 61d57a2f88b9 ("mac80211: ath10k 
add leds support") and broke the 11s support for IPQ4019 and QCA4019 (5GHz) 
firmware versions 10.4-3.5.3-00053, 10.4-3.5.3-00057, 10.4-3.6-00140:

    [  221.620803] ath10k_pci 0000:01:00.0: wmi command 36967 timeout, restarting hardware
    [  221.744056] ieee80211 phy0: Hardware restart was requested
    [  225.130829] ath10k_pci 0000:01:00.0: failed to receive control response completion, polling..
    [  226.170824] ath10k_pci 0000:01:00.0: Service connect timeout
    [  226.170871] ath10k_pci 0000:01:00.0: failed to connect htt (-110)
    [  226.252248] ath10k_pci 0000:01:00.0: Could not init core: -110

This was tested on an A62 with following wireless config:

    config wifi-device 'radio0'
            option type 'mac80211'
            option channel '36'
            option hwmode '11a'
            option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
            option htmode 'VHT80'
            option disabled '0'
            option country US
    
    config wifi-device 'radio1'
            option type 'mac80211'
            option channel '11'
            option hwmode '11g'
            option path 'platform/soc/a000000.wifi'
            option htmode 'HT20'
            option disabled '0'
            option country US
    
    config wifi-device 'radio2'
            option type 'mac80211'
            option channel '149'
            option hwmode '11a'
            option path 'platform/soc/a800000.wifi'
            option htmode 'VHT80'
            option disabled '0'
            option country US
    
    config wifi-iface 'mesh0'
        option device 'radio0'
        option ifname 'mesh0'
        option network 'nwi_mesh0'
        option mode 'mesh'
        option mesh_id 'TestMesh'
        option mesh_fwding '1'
        option encryption 'none'
    
    config wifi-iface 'mesh1'
        option device 'radio1'
        option ifname 'mesh1'
        option network 'nwi_mesh1'
        option mode 'mesh'
        option mesh_id 'TestMesh'
        option encryption 'none'
    
    
    config wifi-iface 'mesh2'
        option device 'radio2'
        option ifname 'mesh2'
        option network 'nwi_mesh2'
        option mode 'mesh'
        option mesh_id 'TestMesh'
        option mesh_fwding '1'
        option encryption 'none

Kind regards,
	Sven
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 833 bytes
Desc: This is a digitally signed message part.
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20190226/1adecfe0/attachment.sig>
-------------- next part --------------
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/mailman/listinfo/openwrt-devel


More information about the openwrt-devel mailing list