[OpenWrt-Devel] [PATCH 5/8] staging: mt7621-gpio: avoid devm_kzalloc() hidden inside declarations and refactor function a bit

Rosen Penev rosenp at gmail.com
Wed May 30 02:36:36 EDT 2018

From: Sergio Paracuellos <sergio.paracuellos at gmail.com>

Driver probe function includes an allocation using devm_kzalloc
which is "hidden" a bit inside the declarations. Extract this
to a better place to increase readability. Also because we are
allocating zeroed memory 'memset' statement is not needed at all.
Condition for checking for a valid gpio id is wrong and it should
be greater or equal instead of only greater so update to be the
good one.

Signed-off-by: Sergio Paracuellos <sergio.paracuellos at gmail.com>
Reviewed-by: NeilBrown <neil at brown.name>
Signed-off-by: Greg Kroah-Hartman <gregkh at linuxfoundation.org>
 .../ramips/files-4.14/drivers/gpio/gpio-mt7621.c      | 11 ++++++-----
 1 file changed, 6 insertions(+), 5 deletions(-)

diff --git a/target/linux/ramips/files-4.14/drivers/gpio/gpio-mt7621.c b/target/linux/ramips/files-4.14/drivers/gpio/gpio-mt7621.c
index 077a7c24df..bbe6cce56d 100644
--- a/target/linux/ramips/files-4.14/drivers/gpio/gpio-mt7621.c
+++ b/target/linux/ramips/files-4.14/drivers/gpio/gpio-mt7621.c
@@ -156,17 +156,18 @@ mediatek_gpio_bank_probe(struct platform_device *pdev, struct device_node *bank)
 	struct mtk_data *gpio_data = dev_get_drvdata(&pdev->dev);
 	const __be32 *id = of_get_property(bank, "reg", NULL);
-	struct mtk_gc *rg = devm_kzalloc(&pdev->dev,
-				sizeof(struct mtk_gc), GFP_KERNEL);
+	struct mtk_gc *rg;
 	int ret;
-	if (!rg || !id || be32_to_cpu(*id) > MTK_MAX_BANK)
+	if (!id || be32_to_cpu(*id) >= MTK_MAX_BANK)
+		return -EINVAL;
+	rg = devm_kzalloc(&pdev->dev, sizeof(struct mtk_gc), GFP_KERNEL);
+	if (!rg)
 		return -ENOMEM;
 	gpio_data->gc_map[be32_to_cpu(*id)] = rg;
-	memset(rg, 0, sizeof(struct mtk_gc));
 	rg->chip.parent = &pdev->dev;

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list