[OpenWrt-Devel] Wifi on ZBT-WE1326 broken after commit 5f7396ebef09

Kristian Evensen kristian.evensen at gmail.com
Tue May 29 11:24:41 EDT 2018


Some days ago I pulled master, built an image and installed it on my
ZBT-WE1326 router. After installing the image, I noticed that wifi is
broken. When looking at dmesg, mt76 reports:

[   14.479853] mt76x2e 0000:01:00.0: MCU message 1 (seq 1) timed out

I initially suspected mt76, but wifi turned out to work fine on other
devices using the mt76-driver (like the ZBT WG3526). I then started a
bisect, and I found out that 5f7396ebef09 ("ramips: improve interrupt
mapping") is the bad commit. Starting from this commit, wifi on the
WE1326 does not work any more.

Since WE1326 and WG3526 is very similar (or supposed to be at least),
I tried to make the DTS' (more) in sync. When I have seen the "MCU ...
timed out" message before, it has usually been because the pinctrl
group was missing entry. However, making the group of the WE1326 match
that of WG3526 had no effect. I also tried to enable the all the other
possible group entries, but no change.

Carrying a local revert of the commit in question is always a
possibility (and does not seem to have any unintentional
side-effects), but I would rather try to fix the problem properly.
Does anyone have any suggestions on where to look?

Thanks in advance for any help,

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list