[OpenWrt-Devel] MR24 sysupgrade seems to be broken

Christian Lamparter chunkeey at gmail.com
Sat Jun 30 09:49:23 EDT 2018

On Saturday, June 30, 2018 10:06:21 AM CEST Russell Senior wrote:
> I just tried updating a Meraki MR24 to current master, from an image a few
> months old and it broke.  I get a new kernel, but an old rootfs.  I have
> some of these deployed where a serial connection is awkward.  It would be
> nice if sysupgrade worked.
Any idea what broke it? From your description "new kernel, old rootfs" it
could be the mtd-utils update to 2.0.2 that broke it:


and this was fixed by me just this month:

(also upstream <http://git.infradead.org/mtd-utils.git/commit/0f833ac73ad631248826386e2918d8571ecf0347>)

so I think you would need to somehow update the mtd-utils
package (ubinfo, ubimkvol, ubirmvol, ...)  on your old routers
before performing sysupgrading in order to fix this.


openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list