[OpenWrt-Devel] Booting D-Link DNS-313, kernel requirements for OpenWRT?

Linus Walleij linus.walleij at linaro.org
Thu Jan 18 10:12:08 EST 2018

On Wed, Jan 17, 2018 at 6:11 PM, Hans Ulli Kroll
<ulli.kroll at googlemail.com> wrote:
> Hi Linus

>> I managed to boot a v4.16-ish kernel and OpenWRT rootfs
>> on the D-Link DNS-313
>> (reference https://dflund.se/~triad/krad/dlink-dns-313/)
> interesting device, especially for the VBUS "solution", so I decided to
> buy for testing.
> I assume VBUS is only connected to GPIO.

It's pretty easy to use. Some twists to get the console soldered
but can hopefully soon be used with a tailored harddrive and just
network access.

>> I used the raidsonic rootfs built from scratch (the prebuilt
>> images on the site seem broken, just contains zeroes).
> OpenWRT is currently in (re)merging status from LEDE
> maybe LEDE images can work.
> I've done a testbuild with current LEDE and ext4 target which fails,
> make be a
> make -j1 V=s
> or a testbuild for my ALIX6F2 give me some light here.

I got it working I think ... the git is a mirror of LEDE these
days so should be the same.

>> sd 0:0:0:0: [sda] 312581808 512-byte logical blocks: (160 GB/149 GiB)
>> sd 0:0:0:0: [sda] Write Protect is off
>> sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't
>> support DPO or FUA
>>  sda: sda1 sda2 sda3 sda4
>> sd 0:0:0:0: [sda] Attached SCSI disk
>> EXT4-fs (sda4): couldn't mount as ext3 due to feature incompatibilities
>> EXT4-fs (sda4): couldn't mount as ext2 due to feature incompatibilities
>> EXT4-fs (sda4): mounted filesystem with ordered data mode. Opts: (null)
>> VFS: Mounted root (ext4 filesystem) readonly on device 8:4.
> read only ?

I fixed it with "rw" in the cmdline, but still the same problem... :(

> I think this must be read write, must verify this with my ALIX6F2 running
> openWRT on a CF card with ext4 as rootfs.

Sadly this doesn't solve it...

I confirmed the problem is something with OpenWRT because
a flat, dirt-simple Busybox rootfs boots fine.

It's probably my fault anyways, just need to figure it out.

Linus Walleij
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list