[OpenWrt-Devel] Fwd: OpenWRT Build Process broken on recent Debian NFS

Mathias Kresin dev at kresin.me
Sun Nov 12 04:26:20 EST 2017

11.11.2017 11:53, Anton Ivanov:
> Resend (apologies, tried to send it to -users by mistake initially).
> Hi all,
> I am observing an interesting issue with the OpenWRT build process when
> building on an up-to-date stretch host. It no longer works on NFS on
> debian (it used to work).
> If I run make with a clean freshly cloned directory tree on a normally
> mounted filesystem it completes OK. If I do a fresh git clone, mount the
> filesystem via nfs I get the following:
> SHELL= flock /var/autofs/local/src/openwrt/tmp/.patch-2.7.5.tar.xz.flock
> -c '    /var/autofs/local/src/openwrt/scripts/download.pl
> "/var/autofs/local/src/openwrt/dl" "patch-2.7.5.tar.xz"
> "e3da7940431633fb65a01b91d3b7a27a" "" "@GNU/patch"'
> flock: /var/autofs/local/src/openwrt/tmp/.patch-2.7.5.tar.xz.flock: Bad
> file descriptor
> Makefile:23: recipe for target
> '/var/autofs/local/src/openwrt/dl/patch-2.7.5.tar.xz' failed
> The results are the same if I mount the system via autofs or directly
> via command line mount. If I run the flock statement "by hand" it
> completes OK as well so this happens only if it is invoked out of the
> openwrt build process (I smell a race here somewhere...).
> I wish I could pinpoint the exact moment it broke. However, as the
> actual problem is with downloads/stamps it is difficult to determine the
> actual point in time it stopped working.
> I tried running the build on a "pristine" stretch with no updates it was
> already broken so this most likely happened somewhere between jessie and
> stretch.
> Any ideas (I do not want to file a Debian bug before narrowing it down)?

Please try again with the following patch applied: 

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list