[OpenWrt-Devel] USB or SD card not mounted in Omega2+ router with LEDE iamge

Arun Kumar arunkumar.1993.2050 at gmail.com
Wed May 31 15:58:09 EDT 2017

Hi All,

I am facing an error where I can't find my USB or SD card and hence cant
upgrade to a new image.

SD Card or USB device plugged in would be usually automounted at
But after sysupgrading to the latest LEDE image, the Omega2+ router detects
the USB device getting plugged in but doesnt display anywhere. Not even in
/dev/sdaX location.

When I plugin a USB device, I get this message:
[ 6382.201671] usb 1-1: new high-speed USB device number 3 using

root at Omega-FB25:/# ls /dev/
bus                 mtd5ro              ttyS1
console             mtd6                ttyS10
cpu_dma_latency     mtd6ro              ttyS11
full                mtdblock0           ttyS12
hwrng               mtdblock1           ttyS13
kmsg                mtdblock2           ttyS14
log                 mtdblock3           ttyS15
memory_bandwidth    mtdblock4           ttyS2
mmcblk0             mtdblock5           ttyS3
mmcblk0p1           mtdblock6           ttyS4
mtd0                network_latency     ttyS5
mtd0ro              network_throughput  ttyS6
mtd1                null                ttyS7
mtd1ro              port                ttyS8
mtd2                ppp                 ttyS9
mtd2ro              ptmx                urandom
mtd3                pts                 watchdog
mtd3ro              random              watchdog0
mtd4                shm                 zero
mtd4ro              tty
mtd5                ttyS0
root at Omega-FB25:/# dmesg | grep usb
[    2.584787] usbcore: registered new interface driver usbfs
[    2.590508] usbcore: registered new interface driver hub
[    2.596060] usbcore: registered new device driver usb
[    2.630320] phy phy-10120000.usbphy.0: remote usb device wakeup disabled
[    2.637134] phy phy-10120000.usbphy.0: UTMI 16bit 30MHz
[    3.118388] usb 1-1: new high-speed USB device number 2 using
[ 6377.744209] usb 1-1: USB disconnect, device number 2
[ 6382.201671] usb 1-1: new high-speed USB device number 3 using

root at Omega-FB25:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                 2.5M      2.5M         0 100% /rom
tmpfs                    61.5M     56.0K     61.5M   0% /tmp
/dev/mtdblock6           28.3M    820.0K     27.4M   3% /overlay
overlayfs:/overlay       28.3M    820.0K     27.4M   3% /
tmpfs                   512.0K         0    512.0K   0% /dev
root at Omega-FB25:/# cd /tmp/mounts
/bin/ash: cd: can't cd to /tmp/mounts

Tried with both USB 1 and USB 2.0 devices. So tried to connect to Wifi and
download new image. But iwconfig is not working.

root at Omega-FB25:/# iwconfig
/bin/ash: iwconfig: not found

Note: This was working fine earlier and I did multiple image swaps between
my personal built ones and official images. I upgraded image from Omega2+
image to LEDE image[1].

Any suggestions on how to overcome this would be helpful.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20170601/02f3a6ba/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list