[OpenWrt-Devel] USB or SD card not mounted in Omega2+ router with LEDE iamge

Felix Fietkau nbd at nbd.name
Thu Jun 1 04:14:17 EDT 2017

On 2017-05-31 21:58, Arun Kumar wrote:
> Hi All,
> I am facing an error where I can't find my USB or SD card and hence cant
> upgrade to a new image.
> SD Card or USB device plugged in would be usually automounted at
> /tmp/mounts
> But after sysupgrading to the latest LEDE image, the Omega2+ router
> detects the USB device getting plugged in but doesnt display anywhere.
> Not even in /dev/sdaX location.
> When I plugin a USB device, I get this message:
> [ 6382.201671] usb 1-1: new high-speed USB device number 3 using
> ehci-platform
Is kmod-usb-storage installed?

> Tried with both USB 1 and USB 2.0 devices. So tried to connect to Wifi
> and download new image. But iwconfig is not working.
> root at Omega-FB25:/# iwconfig
> /bin/ash: iwconfig: not found
> Note: This was working fine earlier and I did multiple image swaps
> between my personal built ones and official images. I upgraded image
> from Omega2+ image to LEDE image[1].
iwconfig is not part of the standard installation, you're not supposed
to use it to connect to networks anyway.
Changing /etc/config/wireless and using reload_config should be used
Please keep in mind that the wifi driver for mt7688 is still quite
buggy, so it won't work very well.
In latest snapshots it might work a bit better, but I don't think it's
stable yet.

- Felix
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list