[OpenWrt-Devel] Ralink RT5390 (RT2800) encrypted mesh issue

Francesco Zanella francesco.zanella at digitallighting.it
Wed Nov 23 09:00:00 EST 2016

Hi all,

I have an issue trying to set up an encrypted mesh network using USB 
modules mounting Ralink RT5390 chipset (RT2800 driver).

I use OpenWrt CC with mac80211 package updated to September, 29th commit.

Using wpasupplicant_mesh or authsae I have the same behavior: nodes 
establish the plink but thy can't ping each other. Sometimes some pings 
work and then no more. Mesh without encryption works fine.

1) I tried to load RT2800 module with nohwcrypt=1 and nothing changed.

2) I tried applying a patch found on the internet, modified in order to 
work with the newer compat-wireless style:


--- a/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
+++ b/drivers/net/wireless/ralink/rt2x00/rt2800lib.c
@@ -9301,6 +9301,7 @@ static int rt2800_probe_hw_mode(struct r)
      ieee80211_hw_set(rt2x00dev->hw, PS_NULLFUNC_STACK);
      ieee80211_hw_set(rt2x00dev->hw, SIGNAL_DBM);
      ieee80211_hw_set(rt2x00dev->hw, SUPPORTS_PS);
+    ieee80211_hw_set(rt2x00dev->hw, MFP_CAPABLE);

       * Don't set IEEE80211_HW_HOST_BROADCAST_PS_BUFFERING for USB devices


but nothing changed.

3) I checked if could be an ARP problem, make the nodes to send an ARP 
broadcast announce every second, but nothing changed.

Could someone help me to solve the issue or give me a hint?

Thank you in advance,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20161123/acf6b241/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list