[OpenWrt-Devel] Having a [kernel] package setting kernel CONFIG_XXX.

Baptiste Jonglez baptiste at bitsofnetworks.org
Sat Jul 16 09:35:28 EDT 2016


On Fri, Jul 15, 2016 at 09:07:07AM +0100, David Fernandez wrote:
> I'm trying to have a kernel package to emnable some kernel configuration
> settings.
> I've tried using the KCONFIG:=CONFIG_XXX in the kernel packages, or creating
> "config KERNEL_XXX" in any kind of package.
> Only to find that the setting makes it as far as $(LINUX_DIR)/.config.set
> but never into $(LINUX_DIR)/.config
> Is there a way to do this?

There is a strange bug with Kconfig, maybe you are hitting it.  Basically,
if a Kconfig symbol does not have a string description attached to it, it
is not possible to select it directly.

Have a look at all the "kconfig hacks" patches that are here as
workaround, for instance:


I tried to track the bug down, but it's quite complex.  It definitely
looks like it comes from the scripts/kconfig tool upstream, not from

OpenWRT/LEDE passes all the kernel symbols it wants to select to
scripts/kconfig from Linux, presumably to handle symbol dependencies in
the kernel.  But kconfig seems to ignore symbols for which there is no
string description (in the KConfig file that defines the symbol).
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 819 bytes
Desc: not available
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20160716/8a7117bd/attachment.sig>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list