[OpenWrt-Devel] LXC is broken on Caos Calmer

Daniel Golle daniel at makrotopia.org
Wed Feb 10 15:03:53 EST 2016

Hi Antonio,

On Wed, Feb 10, 2016 at 09:52:25PM +0200, Antonio Aloisio wrote:
> Hi there,
> I have tried to run lxc on openwrt but it looks to me that those packages
> are broken.

I'm actively using LXC, however, I use a custom overlayfs method to
create OpenWrt containers.
> root at Honeypot:/home/gnuton# lxc-create -t download -n xx
> Setting up the GPG keyring
> ERROR: Unable to fetch GPG key from keyserver.
> lxc_container: lxccontainer.c: create_run_template: 1102 container creation
> template for xx failed

I manually use debootstrap to setup Debian rootfs and throwing that at
LXC works great. I once went through the Debian template and believe it
would make sense to fix it up to work on OpenWrt, so LXC becomes more
useable. Do you have gnupg installed? If not or if GPG stuff fails for
some reason, you can try to to modify the Debian template to use
debootstrap having the signature checks disabled (not ideal,

> I have also installed LXC LuCi web GUI and it doesn't work too.
> The GUI would allow me to create a openwrt based conatainer, but the truth
> is that there is no such template available as you may see from the above
> list.

I never tried lxc-download nor the LuCI GUI which is afaik just a
proof-of-concept and not that usable in it's current state.

> Digging further I had a look at the source code and I noticed there some
> problems too
> for instance
> https://github.com/openwrt/packages/blob/master/utils/lxc/patches/030-lxc-download.patch
> points lxc-download to use a not working server.

If you feel like helping, please suggest a patch via github.

> I would like to know what's the status of LXC, is it supposed to work or
> those packages are unmantained?

Good question... @luka ?


openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list