[OpenWrt-Devel] Unable to create GRE interface using netifd

pothuganti sridhar pothuganti.sridhar at gmail.com
Thu Nov 19 04:38:28 EST 2015


Hi All,

I am using netifd version "PKG_VERSION:=2014-09-08.1". Following is my
network config file.


*config interface loopback*

*        option ifname   lo*

*        option proto    static*

*        option ipaddr   127.0.0.1*

*        option netmask  255.0.0.0*



*config interface vlan1*

*        option ifname   eth2*

*        option proto    static*

*        option ipaddr   192.168.0.1*

*        option netmask  255.255.255.0*



*config interface wan1*

*        option ifname   eth0*

*        option proto    static*

*        option ipaddr   172.31.3.8*

*        option netmask  255.255.0.0*



*config interface gre1*

*        option peeraddr 192.168.11.5*

*        option ipaddr 172.31.3.8*

*        option proto gre*

*        option df true*

*        option zone tunnel*

*        option tunlink wan1*



*config interface 'gre1_static'*

*        option proto 'static'*

*        option ifname '@gre1'*

*        option ipaddr '10.232.90.101'*

*        option netmask '255.255.255.0'*


With the above configuration I am unable to create the GRE interface.  With
further debugging I found out that, GRE interface addition is failing in
function “proto_shell_check_dependencies” with check “if (dep->dep.iface)”
being NULL for interface WAN1. Following are the logs.

*Jan  2 16:21:02 RV340 netifd: proto_shell_notify:723
blobmsg_get_u32(tb[NOTIFY_ACTION]):6*

*Jan  2 16:21:02 RV340 netifd: proto_shell_check_dependencies:87
ifname:(null) name:gre1*

*Jan  2 16:21:02 RV340 netifd: proto_shell_check_dependencies:90
interface:wan1*

*Jan  2 16:21:02 RV340 netifd: proto_shell_check_dependencies:94 making
false  interface:wan1*

*Jan  2 16:21:02 RV340 netifd: Interface 'gre1', available=0*

*Jan  2 16:21:02 RV340 netifd: interface_set_available:369 calling
__interface_set_down*

*Jan  2 16:21:02 RV340 netifd: run teardown for interface 'gre1'*

*Jan  2 16:21:02 RV340 netifd: netifd_start_process:138*

*Jan  2 16:21:02 RV340 netifd: netifd_start_process:174  bin:./gre.sh*



Note: I have added some more logs to find out where it is getting failed.

Is my configuration proper? Or any thing am I missing? I am unable find out
where I am going wrong. any pointers would be grateful.

Thanks,
Sridhar
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20151119/d72c7a9b/attachment.htm>
-------------- next part --------------
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


More information about the openwrt-devel mailing list