[OpenWrt-Devel] ath9k_htc: Target is unresponsive

Caleb James DeLisle cjd at cjdns.fr
Mon May 25 12:57:55 EDT 2015

I've seen a similar issue with the toshiba wlm20u2 where it says it's
transferring htc_9271.fw but that's actually the wrong fw so the device
crashes, the solution for me was to specify the device as AR9280_USB
in the ath9k_hif_usb_ids struct as per the following:

Maybe this is helpful...

On 05/25/2015 05:59 PM, Luca Olivetti wrote:
> El 25/05/15 a les 17:27, Bruno Randolf ha escrit:
>> On 05/25/2015 03:38 PM, Luca Olivetti wrote:
>>> This is the message I get when I plug  a tp-link tl-wn722n (which is
>>> working fine both in an ubuntu desktop and on a mageia laptop):
>>> [  547.804000] usb 1-1: new high-speed USB device number 5 using ifxusb_hcd
>>> [  548.020000] usb 1-1: ath9k_htc: Firmware htc_9271.fw requested
>>> [  549.296000] usb 1-1: ath9k_htc: Transferred FW: htc_9271.fw, size: 50980
>>> [  550.304000] ath9k_htc 1-1:1.0: ath9k_htc: Target is unresponsive
>>> [  550.308000] ath9k_htc: Failed to initialize the device
>>> Just to exclude a problem with the usb port, I tried with an rt73 based
>>> stick I have and it works fine.
>>> I have a different firmware on my desktop system, I tried it but the
>>> result is the same.
>>> This is with openwrt trunk on an astoria arv7518pw (lantiq xway)
>> Maybe a problem with the USB power supply. Can you try with a powered
>> USB hub?
> Yes, I thought so, but I don't have a powered usb hub :-/
> Bye

Satire is the escape hatch from the cycle of sorrow, hatred and violence. #JeSuisCharlie
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list