[OpenWrt-Devel] Device tree issues with TL-WDR4900 (mpc85xx) and kernel 4.0.1

Heiner Kallweit hkallweit1 at gmail.com
Mon May 4 16:45:54 EDT 2015

I tried to make the TL-WDR4900 work under kernel 4.0.
Adjusting the platform-specific patches was quickly done and the system boots.
However I get the following error messages.

[    2.959975] /leds/system: could not get #gpio-cells for /soc at ffe00000/gpio-controller at f000
[    2.968276] leds-gpio: probe of leds failed with error -22
[   34.622909] /buttons/reset: could not get #gpio-cells for /soc at ffe00000/gpio-controller at f000
[   34.631383] gpio-keys buttons: Failed to get gpio flags, error: -22
[   34.637657] gpio-keys: probe of buttons failed with error -22

I'm not a device tree expert, what I checked so far:
The gpio-related section in tl-wdr4900-v1.dts is empty

gpio0: gpio-controller at f000 {

However #gpio-cells is defined in fsl/pq3-gpio-0.dtsi and this file is imported by fsl/p1010si-post.dtsi.
And fsl/p1010si-post.dtsi is imported by tl-wdr4900-v1.dts.

This worked under 3.19 (despite the fact that 3.19 was never officially supported for this device),
seems like something with the DT handling has changed in 4.0.
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list