[OpenWrt-Devel] Raspberry Pi 2 sysupgrade

Bruno Randolf br1 at einfach.org
Fri Jul 10 13:18:15 EDT 2015

On 07/09/2015 06:44 AM, John Crispin wrote:
>> I have the below change to add rudimentary support for sysupgrade on the
>> Raspberry Pi. I looked at the way platform_copy_config() is implemented
>> for x86 and tried to do the same, but I get the following error on mount:
>> mount: mounting /dev/mmcblk0p2 on /mnt failed: Device or resource busy
> in that case its either still flushing the cache or has not been
> properly unmounted i think. you could try adding the "partprobe" tool to
> force a rescan of the table but i am not sure this is the problem here

You are right. I tried 'partprobe -s /dev/mmcblk0' and it shows the
partitions correctly but mount still fails.

I also tried 'sync' before trying to mount to flush the cache with no

So the suspect is that it has not been properly unmounted. So I tried to
'unmount -f /dev/mmcblk0p2' but that fails with "umount: can't forcibly
umount /dev/mmcblk0p2: Invalid argument"

Here are the mounts at that time:

rootfs on / type rootfs (rw)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
tmpfs on / type tmpfs (rw,nosuid,nodev,noatime)

"rootfs on / type rootfs (rw)" should be the RAM rootfs, no?
How and were to unmount / correctly?

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list