[OpenWrt-Devel] lighttpd 1.4.36 and file descriptors limit issue - OpenWrt related?

Rafał Miłecki zajec5 at gmail.com
Thu Aug 13 14:42:48 EDT 2015

On 13 August 2015 at 20:16, Jonas Gorski <jogo at openwrt.org> wrote:
> On Thu, Aug 13, 2015 at 8:00 PM, Rafał Miłecki <zajec5 at gmail.com> wrote:
>> There is an issue with handling relatively big (4 MiB+) files in
>> lighttpd after the upgrade to the 1.4.36:
>> https://github.com/openwrt/packages/issues/1658
>> It seems lighttpd is running out of file descriptors and is replying with:
>> 413 - Request Entity Too Large
>> I also reported this issue upstream:
>> http://article.gmane.org/gmane.comp.web.lighttpd/5370
>> I received following suggestion (on the IRC) pointing OpenWrt kernel:
>> [19:45] <sztanpet> i shall blame the openwrt kernel
>> [19:45] <rmilecki> sztanpet: what exactly? I can modify the config if needed
>> [19:45] <rmilecki> or the sources if you have anything to test
>> [19:45] <sztanpet> i have no idea
>> [19:45] <rmilecki> oh
>> [19:46] <sztanpet> but since the issue is such a core issue that
>> everyone would be seeing it and that is not the case, that tells me
>> its probably not lighttpd
>> Can you think of anything in OpenWrt kernel that could cause such a problem?
> Have you tried if changing the libc makes any difference? Might be a
> bug in musl, might a not quite proper usage that glibc allows, but
> musl doesn't, etc pp.

I was actually using 15.05 (which uses uClibc). I tried OpenWrt's
trunk (which uses musl) and the problem exists there too.

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list