[OpenWrt-Devel] TPLink TL-WR1043ND v2.1 WAN bug recurrence in stock firmware wr1043v2_en_3_17_38 (140613)

Aaron Z aczlan+openwrt at gmail.com
Tue Sep 9 05:54:07 EDT 2014

I have run into what seems to be a re-occurrence of the WAN bug on a TPLink
TL-WR1043ND v2.1 with the stock firmware labled wr1043v2_en_3_17_38
The WAN port works fine with the stock firmware, but is seen as down when I
flash over the OpenWRT firmware.
I have tried BBrc3, BBrc2 and trunk (r42429 from 7 Sep 2014).
My initial flash was from the stock firmware to the "Factory" BBrc3 image.
I then switched to the Sysupgrade rc3 image. I also tried both the
"Factory" and the "Sysupgrade" images from rc3 and trunk.
I have tried flashing with both "sysupgrade /tmp/tplink.bin" and "mtd -r
write tplink.bin firmware" (after dropping the firmware into the /tmp
folder with WinSCP).

I also tried flashing back to stock after using dd to remove the "boot"
portion of the image (dd if=orig.bin of=tplink.bin skip=257 bs=512). When I
did that, the WAN port started working again.

Any suggestions on where to go from here?
I can make what I need to do (setting up a trunk with a couple of vlans)
work by splitting off a LAN port from the switch but it would be nice to
use the WAN port for my "Uplink" and have 4 "LAN" ports available to plug
in other devices.

Any suggestions?


Aaron Z
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20140909/1d00d3e2/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list