[OpenWrt-Devel] uqmi - Specifying Link Protocol (libqmi --device-open-net=net-802-3 option)

Aaron H spam_catcher911 at hotmail.com
Mon Oct 13 00:27:02 EDT 2014

FYI, just tried running "qmicli -d /dev/cdc-wdm0 --wda-set-data-format=802-3" while the card was reporting "connected". The setting appeared to work as confirmed with "qmicli -d /dev/cdc-wdm0 --wda-get-data-format". Also, the data session is now disconnected as per "uqmi -d /dev/cdc-wdm0 --get-data-status".

From: spam_catcher911 at hotmail.com
To: nbd at openwrt.org; openwrt-devel at lists.openwrt.org
Subject: RE: [OpenWrt-Devel] uqmi - Specifying Link Protocol (libqmi --device-open-net=net-802-3 option)
Date: Sun, 12 Oct 2014 21:21:07 -0700

I'm currently testing uqmi-2014-10-02 and am having problems getting the dhcp address still.
It appears autoconnect on my card is enabled and although the --set-autoconnect command returns without error, it does not disconnect the data session.  I'm not aware of a way to obtain the data session handle, so I'm not sure how to stop the session through any other means.
I tried running the command "uqmi -d /dev/cdc-wdm0 --set-data-format 802.3" and although it comes back without error, it appears the value is not taken as libqmi reports the link layer is still raw IP.  Maybe this is because the card won't allow the data format to be changed while in session (and it's stuck in session)?
> Date: Thu, 2 Oct 2014 14:22:25 +0200
> From: nbd at openwrt.org
> To: spam_catcher911 at hotmail.com; openwrt-devel at lists.openwrt.org
> Subject: Re: [OpenWrt-Devel] uqmi - Specifying Link Protocol (libqmi --device-open-net=net-802-3 option)
> On 2014-10-02 11:22, Felix Fietkau wrote:
> > On 2014-10-01 21:12, Spam Catcher wrote:
> >> I'm trying to use uqmi with a Sierra Wireless MC7354 and MC7750.  On
> >> both modules I'm able to bring up a connection to the cell network, but
> >> cannot send or receive anything on the wwan0 interface. After much
> >> digging I found an option for libqmi that specifies using ethernet
> >> headers instead of raw IP (--device-open-net=net-802-3).  When I
> >> specified this option with libqmi, both modules came up with an IP
> >> address immediately and allowed traffic to pass without issue. Is there
> >> an equivalent parameter I can use for uqmi?  Or maybe even a compilation
> >> flag to have it always requested?
> >> 
> >> I'll only be using LTE mode, so the firmware bug where 3G and 4G behave
> >> differently shouldn't affect me (I think). If the functionality's not
> >> already in uqmi for requesting ethernet headers, then I'd gladly donate
> >> .25BTC (~ $100) to someone for implementing this.
> > Since I'm working on uqmi today already, I'll take care of this as well.
> > I'll let you know when the changes are available for testing.
> This feature is implemented now, as of r42724 - please test.
> By the way, the script sets the mode at startup time automatically.
> - Felix
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20141012/494cae4e/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list