[OpenWrt-Devel] How is the current status of support for Ubnt NanoStation Loco M5?

Bernd Naumann bernd at kr217.de
Sat Nov 1 07:37:24 EDT 2014

Hash: SHA1


Yesterday I was able to find the ubnt-LOCO-m-wm firmware. I missed it
because it is not documented in the wiki for models after 2014. I will
fix this during the day. Current trunk works fine so far.

Another curious thing was: I flashed the factory image over AirOS, and
later I wanted to use an other version, so I used the factory image
version again, but the platform check failed; BUT the sysupgrade image
just worked fine. Normally it does not matter if you use the factory
or sysupgrade image? But in the cause of ubnt devices the factory is
not the size of the ROM, is this supposed to be so?

To the serial connection:
So nobody replyed to my question, is there some threat to damage the
board if I'm brute force all variants (TX, RC, GND)? Like the older
boards, I may need no VC, so it couldn't be something go wrong, right?

Thanks and BR,

On 10/31/2014 01:15 AM, Bernd Naumann wrote:
> Hi,
> The wiki says [0] that for Ubnt NS Loco M5 (build in the year
> 2014) someone has to use the **xw** firmware like 
> *openwrt-ar71xx-generic-ubnt-nano-m-xw-squashfs-factory.bin*. But
> this do not work for my model with "Test date: 01/24/14", which 
> came with AirOS V 5.5.7.
> Yes, after flashing there is OpenWRT on the box, but it is not
> booting properly. Cause of my lacking knowledge I do not know how
> to debug or offer a better explanation. I found some forum rumors
> which indicate that OpenWRT will not finish the boot procedure, but
> there where no explanation why.
> I was able to flash back to the original ubnt firmware [1] via
> tftp.
> At first I had tested BB 14.07 and later found that **xw** support 
> just came with r42549. So I tried the current trunk snapshot, but
> with the same not working result.
> Can someone please give me a hint how to debug, or how to get
> OpenWRT working on a /brand new/ NanoStation Loco M5?
> Also has someone experience how the apply a serial adapter to the 
> board, I was unable to find any information for these new boards.
> If someone can say where to put TX, RX and GND I can put an adapter
> to it, and can provide a boot log - but I'm to scared to just try
> it ;)
> This board has no jtag/serial 10 pin thingsy like the Loco M2, but
> 4 'holes' which look like these on boards like tp-link
> wr841/wr1043. (Sorry I dont no how to call it in english).
> Best regards and thanks for any help, Bernd
> [0] http://wiki.openwrt.org/toh/ubiquiti/nanostationm5 [1]
> XW.v5.5.10.24238.141001.1641.bin

- -- 
Bernd Naumann <bernd at kr217.de>

PGP:   0xA150A04F via pool.sks-keyservers.net
XMPP:  bn at weimarnetz.de
Version: GnuPG v1.4.12 (GNU/Linux)

openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list