[OpenWrt-Devel] [PATCH] brcm47xx: image: build alternative TRX using less optimized LZMA

Stephen Parry sgparry at mainscreen.com
Mon Aug 25 22:34:08 EDT 2014

No sorry - I did not explain carefully enough:
1. About 9 months ago I built a trx using trunk that flashed and worked OK.
2. Two weeks ago I built a new image. This loaded and tested fine as ELF via tftp boot so I flashed the trx using MTD command. the resulting image hung after "starting program at 8001000" just as you described.
3. I incorrectly thought the problem was that I had flashed incorrectly so tried CFE flash command instead.
4. I got parameters of flash command wrong and overwrote CFE.
5. I saw your patch and kicked myself for not having seen it sooner.

I was supporting (seconding) your patch by trying to explain that had I seen it 15 minutes earlier it would have saved me from a dead router.

Rafa? Mi?ecki <zajec5 at gmail.com> wrote:
>First of all, I really don't think this patch itself may cause any
> problem with MTD/partitions/bricking.

> I don't understand much of your report. > It was working previously? But
> then you say it was hanging? Then you > mention some MTD command
> failing...? What did you do in CFE? Which firmware did you try to
> install at all? What was the log of firmware booting & destroying your
> CFE?
> This "report" says nothing :(
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20140826/e701c0f2/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list