[OpenWrt-Devel] [PATCH] gre: Generic Routing Encapsulation package support

Steven Barth cyrus at openwrt.org
Sun Aug 3 05:37:51 EDT 2014


tbh. we should get rid of that option network stuff.
I merged it anyway at first so we can get some experience with this 
gre-integration.
Normally you should use something like this instead:

config interface mygre
         option proto 'gre'
         option ipaddr '203.0.113.2'
         option peeraddr '192.0.2.42'
         option network 'tunnel'

config interface mygre_static
	option proto static
	option ifname @mygre
	option ipaddr 10.0.0.217
	option netmask 255.255.255.0


Same should hopefully work with gre and gretap as source.
If this does the trick I'm for removing the option network stuff.



Cheers,

Steven
_______________________________________________
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel



More information about the openwrt-devel mailing list