[OpenWrt-Devel] Antenna selection not working as expected

Fernando Frediani fhfrediani at gmail.com
Fri Aug 1 17:30:41 EDT 2014


I have a TL-WR1043ND v1 running Barrier Breaker 14.07-rc2 and have a 
Sector Antenna connected to the first antenna port. On the other two I 
have removed the original Omni antennas.
In order to tell the router that I want to work only with the Sector 
antenna (first port) I have added the following option on 
/etc/config/wireless radio configuration
*option rxantenna '0x4'**
**            option txantenna '0x4'*

Where 4 means 100 in binary which is equivalent to the first antenna On 
However the router doesn't seem to obey it.
If I run:*
iw phy phy0 info | grep -i ant *
I get the following:
          Available Antennas: TX 0x7 RX 0x7
         Configured Antennas: TX 0x7 RX 0x7
While I would expect to see the "Configured Antennas" with different values.

Does anyone have any idea if this is not working as expected or if it's 
something to do with the ath9k driver or if I can try a different 
driver, etc ?
Previously I was running the snapshot version before RC2 and getting the 
same result.
If anyone has any clue would be greatly appreciated.

Best regards,


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.infradead.org/pipermail/openwrt-devel/attachments/20140801/865ae393/attachment.htm>
-------------- next part --------------
openwrt-devel mailing list
openwrt-devel at lists.openwrt.org

More information about the openwrt-devel mailing list