[FS#4049] Stop network configuration after defining a network bridge

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Wed Sep 22 06:10:55 PDT 2021


THIS IS AN AUTOMATED MESSAGE, DO NOT REPLY.

A new Flyspray task has been opened.  Details are below. 

User who did this - Zbyněk Kocur (zokl) 

Attached to Project - OpenWrt/LEDE Project
Summary - Stop network configuration after defining a network bridge
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Medium
Priority - Very Low
Reported Version - openwrt-21.02
Due in Version - Undecided
Due Date - Undecided
Details - I ran into a problem with the order of placement of the bridge definition between interfaces. The network configuration execution stops after the network bridge definition. Anything that is not executed after that. The following is an example of placing routing entries before and after the network bridge definition. 


config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd58:e16c:06bf::/48'

config interface 'mgmt'
        option enabled '1'
        option proto 'static'
        list ipaddr '172.16.10.2/24'
        option device 'br-mgmt'

config device 'br_mgmt'
        option name 'br-mgmt'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'
        list ports 'eth2

config route 'mgmt1'
        option interface 'mgmt'
       option gateway '172.16.10.1'
        option target '172.16.12.0/24'

config route 'mgmt2'
        option interface 'mgmt'
       option gateway '172.16.10.1'
        option target '172.16.11.0/28'


Routing table output

root at FTW2:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.16.10.0     0.0.0.0         255.255.255.0   U     0      0        0 br-mgmt


Good possition 

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd58:e16c:06bf::/48'

config interface 'mgmt'
        option enabled '1'
        option proto 'static'
        list ipaddr '172.16.10.2/24'
        option device 'br-mgmt'

config route 'mgmt1'
        option interface 'mgmt'
       option gateway '172.16.10.1'
        option target '172.16.12.0/24'

config route 'mgmt2'
        option interface 'mgmt'
       option gateway '172.16.10.1'
        option target '172.16.11.0/28'

config device 'br_mgmt'
        option name 'br-mgmt'
        option type 'bridge'
        list ports 'eth0'
        list ports 'eth1'
        list ports 'eth2


Routing table output

root at FTW2:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
172.16.10.0     0.0.0.0         255.255.255.0   U     0      0        0 br-mgmt
172.16.11.0     172.16.10.1     255.255.255.240 UG    0      0        0 br-mgmt
172.16.12.0     172.16.10.1     255.255.255.0   UG    0      0        0 br-mgmt


More information can be found at the following URL:
https://bugs.openwrt.org/index.php?do=details&task_id=4049

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.



More information about the openwrt-bugs mailing list