[FS#3266] Multicast does not work over bridge with AP/VLAN interfaces

OpenWrt Bugs openwrt-bugs at lists.openwrt.org
Mon Aug 3 01:28:32 EDT 2020


A new Flyspray task has been opened.  Details are below. 

User who did this - Erik Larsson (whooo) 

Attached to Project - OpenWrt/LEDE Project
Summary - Multicast does not work over bridge with AP/VLAN interfaces
Task Type - Bug Report
Category - Base system
Status - Unconfirmed
Assigned To - 
Operating System - All
Severity - Low
Priority - Very Low
Reported Version - Trunk
Due in Version - Undecided
Due Date - Undecided
Details - Devices:
MikroTik RouterBOARD wAP G-5HacT2HnD with OpenWRT r13630-635f111148
EnGenius EAP1300 with OpenWRT r14017-c90db26e05

I have a wifi setup with EAP and dynamic vlan assigment from a radius server.
Clients can connect and both unicast and broadcast (DHCP) works fine, but multicast does not, so IPv6 SLAAC does not work for example.
On the APs I can see the multicast packets being sent out on the the AP/VLAN interfaces (tcpdump -n -i wlan1.10 multicast), but none of the three clients (linux laptop and two iOS devices) receives them.
I have tried enabling multicast_to_unicast, multicast_snooping and hairpin_mode by hand in sysfs, doesn't make any difference, also tried disabling multicast_router.
It sometimes works on the MikroTik device, but mostly does not.

My wireless config (it's the same on both devices for both radios):
config wifi-iface 'myssid_5'
        option mode 'ap'
        option ssid 'myssid'
        option hidden '1'
        option encryption 'wpa3-mixed'
        option auth_server 'authserver'
        option auth_secret 'secret'
        option dynamic_vlan '2'
        option vlan_tagged_interface 'eth0'
        option max_inactivity '1800'
        option device 'radio0'
        option mobility_domain 'f1f1'
        option nasid 'mynasid'
        option pmk_r1_push '1'
        option ieee80211r '1'
        option rsn_preauth '0'
        option isolate '1'
        option vlan_bridge 'br-vlan'
        option vlan_naming '0'
        option ieee80211w '1'
        list r0kh '....'
        list r0kh '....'
        list r0kh '....'
        list r0kh '....'
        list r1kh '....'
        list r1kh '....'
        list r1kh '....'
        list r1kh '....'

More information can be found at the following URL:

You are receiving this message because you have requested it from the Flyspray bugtracking system.  If you did not expect this message or don't want to receive mails in future, you can change your notification settings at the URL shown above.

More information about the openwrt-bugs mailing list